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Guidelines Before Updating
BEFORE PROCEEDING with the Update, the following criteria must be met:

1.	 To update to Avimark 18.10.0 or higher, you MUST be running Client Server. See 
“Appendix A: Installing Client/Server” on page 12.

2.	 No workstations can be in Standalone mode. See “Appendix B: Standalone Mode” on 
page 17.

3.	 Any computer running Windows XP or Vista will NOT work with Avimark 18.10.0 and 
above. Please review the Hardware Requirements.

4.	 Check your version of Avimark by going to Help > About Avimark from the Client 
Information Display. If you are running Avimark Version 2011.0.7 or below, do not 
proceed without first speaking with Technical Support to learn about the Updating 
Procedure.

5.	 There are services that can affect the update from running properly. It is recommended 
to check for these services and stop them before the update, and then resume them 
once everything has been updated. 

AllyDVM DataPoint SyncVet

Bitwerx Greenline VetData

For assistance, call 855.266.5864 or email AvimarkUpdates@covetrus.com or submit an update 
request form.

This version includes Antech’s online platform, HealthTracks, through an immersive experience. This 
upgrade will enhance your ordering and result-viewing processes with HealthTracks.

Advantages of the Immersive Experience:

	• Access to HealthTracks: Seamless integration with your software.

	• Test Guide: Comprehensive insights into all available tests.

	• Advanced Features: Immediate access to AI recommendations, new analyzers, and trending options for 
both Reference Lab and In-House Diagnostics. 

https://softwareservices.covetrus.com/global/solution/computer-hardware/
mailto:AVImarkUpdates%40covetrus.com?subject=AVImark%20Update%20Request
https://go.covetrus.com/update-avimark/
https://go.covetrus.com/update-avimark/
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Important Notes:
1.	 Early Experience Program (EEP): This is a pilot program, and some changes (e.g., hot keys will not work 

in the immersive view) are expected.

2.	 No Rollback: Once installed, the immersive experience cannot be reverted.

Installing the Update

Open Avimark Guardian
1.	 With your mouse over the Avimark Guardian icon on the Desktop, right-click and from the shortcut 

menu, choose Run as administrator.

2.	 In Avimark Server Guardian, with the option Open Avimark Server selected, click Run.

3.	 The Avimark Server opens.
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Run a Backup
1.	 Before backing up your Avimark files, be sure all workstations have closed Avimark.

2.	 From Avimark Server, click on Utilities > BACK UP Avimark Files.

3.	 Click Yes to proceed with the backup.
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Backup Options

1.	 Select the option Program files and Verify backup then click Backup.

2.	 Once the backup is finished, a Backup verified successfully message will appear. Click OK on the 
message.
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3.	 Open Windows File Explorer and navigate to the backup location. Verify the backup has size and 
today’s date.

Download and Install the Update
1.	 If you closed Avimark Server, follow the steps on page 4 to open Avimark Guardian and Avimark 

Server.

2.	 From Avimark Server, click on Utilities > Update Avimark.

3.	 Click Yes on the message to proceed with the download.

4.	 The Avimark Update Assistant will open.

5.	 Read the Agreement and check I Have Read and agree to the terms... Click Next.
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6.	 Select Download the latest official release. Click Next.

7.	 This will take you to the Download option. You will see that it displays the new version, old version and 
the unique Avimark zip file that is downloaded into the Avimark folder. 
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8.	 Click Download. It will start downloading the file from the Avimark download site and place it in the 
Avimark folder.

9.	 After the files have been downloaded, it will start the install process.
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10.	 Click Run for both prompts that will appear for Security Updates.

11.	 Click Update to proceed with the update process.

12.	 Before the actual file update happens, the program will automatically rebuild the Reminder and Entry 
History indexes.  These are some of the larger indexes so please allow for enough time for this process.
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13.	 Once the rebuild is complete, you will proceed with the update process and at the end, it will rebuild 
any indexes that need it, this will include the Reminder and Entry History indexes again along with any 
others that have issues. 

14.	 Open Avimark Guardian and verify the Service is running after update.

After Updating
Restart Services

If the following services were stopped before the update, it is recommended to start them 
after the update: 

AllyDVM DataPoint SyncVet

Bitwerx Greenline VetData



877-999-2838  |  covetrus.com   

UPDATING AVIMARK USER GUIDE

12

Appendix A: Installing Client/Server

Client/Server Edition
To determine if you are running the Avimark Client/Server Edition:

1.	 Open Avimark.

2.	 From the menu bar, click on Help > About Avimark.

3.	 At the very top it will indicate if you are running the Client/Server Edition. If you are, you are good to go 
for updating to 18.10.0 or higher.

Client/Server: Explanation and Benefits
As of 2018 versions of Avimark, running Avimark through Client Server is mandatory. This option allows 
Avimark to access the data files in a more direct way asking for larger sets of information instead of the 
previous method that had more requests for smaller sets of information causing undue slowness for some 
clinics because of network traffic generated. It also allows all of the workstations to talk to the Avimark 
server service which will get the information from the server which helps to eliminate file locking errors. 

Using the Client/Server application can be defined as:

	• Client — Avimark.exe [program]

	• Server — Avimarkserver.exe [Application program]

	• AvimarkGuardian.exe [Service program]

These files will be inactive until you switch to using Client/Server.
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The main change you will notice when using the Client/Server feature is the new AvimarkGuardian program. 
The AvimarkGuardian is an executable program that will run in the background on your server to allow 
AvimarkServer.exe to be run as a Service. It can be set up to start with Windows and can be thought of as a 
“controller” to control the AvimarkServer.exe file.

A new shortcut, AvimarkGuardian.exe, will need to be created on the Server. In addition to using Client/
Server on your local network, you can also connect to Avimark through the internet.

If you run more than one active database and wish both to run Client/Server, you will need to contact 
Avimark Technical Support to set up the second database.

Switch from Classic to Client/Server
1.	 Open your Avimark folder on the server, locate the file AvimarkGuardian.exe, right-click on it, and click 

Send to > Desktop (Create Shortcut).

2.	 On the Shortcut to Avimark Guardian, right-click > Run as Administrator. The Avimark Server 
Guardian window opens.

3.	 Click Open Avimark Server and click Run.

4.	 At the top, click on File > Options. Set a four digit password and leave the port to 9191 then click Done.
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5.	 Close the Avimark server window and, in the Avimark Server Guardian window, choose Install Avimark 
as a Hidden Service and click Run. The message at the bottom will change once this is completed to, 
“Avimark Server is currently running as a service.”

If the message at the bottom displays, “Avimark Server is installed as a service, but is not 
currently running,” click Start the Service, and click Run.

6.	 Click Done on the Guardian window.

7.	 (optional) If double-clicking on the Avimark.exe icon does not connect you to the server window, try 
connecting this way: 
 
On the Avimark Shortcut, right-click > Properties. At the end of the Target field (after the .exe) add a 
space then type /connect (see the image below for an example). Click Apply and then OK. 

When finished installing Client Server, you will remove the /connect from the properties.

8.	  Open Avimark.

9.	 The screen below should open. Click Connect as Client/Server and check the option to Save 
Changes, and click Next. (Save changes will make this option global so all your other computers will 
connect this way. Without this option checked only this computer will connect this way for this log on 
only.)
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10.	 The next screen provides the fields to enter in the server name, password, and port number.

a.	 Name or address of the computer should be the server’s full name or the IP address of the server.

Only use the IP address for the address box if the server has a static IP.

b.	 The server password is a password created by Avimark for additional security. You should not 
have to change this option unless you changed the Avimark server password.

c.	 The port number is defaulted to 9191 unless you have changed the Avimark server port. You 
should leave this option blank.

d.	 Use Compression should remain unchecked unless you are primarily accessing Avimark through 
the internet instead of on a local network or if you use wireless on most of your workstations.

If you use a firewall, you will need to make sure the Avimarkserver.exe and Avimark.exe are 
excluded from the firewall. Also, the designated port number is unblocked on the firewall. 
If you need help setting up your firewall, contact Avimark Support.

Several functions previously located in the Utilities menu have been moved and must be 
accessed through the Avimark Guardian. To access these options: rebuild indexes, backup 
Avimark files, updateAvimark, Sidekick, and Apply Reminders. You will close Avimark on 
all computers and the server then double-click on Avimark Guardian and click Run. Click 
Utilities and make your selection.
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11.	 Fill out a Support Request Form letting us know your clinic name, phone number, and that you 
switched to Avimark Client/Server. 

This is important because Tech Support is keeping track of our users on Client/Server. This enables us 
to track improvements in speed-related problems and make sure if any Client/Server-specific issues 
were ever to arise, we would be able to contact you quickly via e-mail.

https://softwareservices.covetrus.com/contact-support/
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Appendix B: Standalone Mode

Determine if in Standalone Mode
To check if a workstation is in standalone mode, follow the steps below.

1.	 Right-click on the Avimark Shortcut located on the workstation’s desktop.

2.	 Select Properties from the shortcut menu.

3.	 In the Target field, look for /standalone after the exe.

4.	 If /standalone is in the Target field, use your backspace or delete key to remove it.

5.	 Following the directions under “Switch from Classic to Client/Server” on page 13, this will connect 
the workstation to the server.

OR
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You may go to Help > About Avimark and next to Parameters, it will show if in “/standalone”.
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Appendix C: Stop/Start Services
As indicated on page 3 of this guide, there are services that can affect the update from running properly. It 
is recommended to check for these services and stop them before the update, and then resume them once 
everything has been updated. 

AllyDVM DataPoint SyncVet

Bitwerx Greenline VetData

1.	 From the Windows Taskbar, search for Services.

2.	 Click on Services to open the window.

3.	 Scroll through the list of Services. If any of the services listed above appear in the list, right-click on the 
service then choose Stop.

4.	 After all services have been stopped, proceed with the Avimark update.
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5.	 When the update is complete, start the services:

a.	 Open Windows Services.

b.	 On the service, right-click > Start.
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